EIGRPの設定

目的

異なるネットワークに所属している2台のPCをお互いに通信させます。
ルーティングプロトコルはEIGRPを使用します。

EIGRPの設定方法を学びます。

接続構成

設定

R1の設定

R1(config)#int f0/0
R1(config-if)#ip add 10.1.1.1 255.255.255.0
R1(config-if)#no shut

R1(config-if)#int f1/0
R1(config-if)#ip add 10.2.1.1 255.255.255.0
R1(config-if)#no shut

R1(config)#router eigrp 1
EIGRPをAS番号1で動作させる
R1(config-router)#network 10.1.1.0
R1(config-router)#network 10.2.1.0

R2の設定

R2(config-if)#int f0/0
R2(config-if)#ip add 10.3.1.1 255.255.255.0
R2(config-if)#no shut

R2(config)#int f1/0
R2(config-if)#ip add 10.2.1.2 255.255.255.0
R2(config-if)#no shut

R2(config)#router eigrp 1
EIGRPをAS番号1で動作させる
R2(config-router)#network 10.2.1.0
R2(config-router)#network 10.3.1.0

PC-1の設定

PC-1> ip 10.1.1.100/24 10.1.1.1
Checking for duplicate address...
PC1 : 10.1.1.100 255.255.255.0 gateway 10.1.1.1

PC-1> save
Saving startup configuration to startup.vpc
. done

PC-2の設定

PC-2> ip 10.3.1.100/24 10.3.1.1
Checking for duplicate address...
PC2 : 10.3.1.100 255.255.255.0 gateway 10.3.1.1

PC-2> save
Saving startup configuration to startup.vpc
. done

設定確認

ルーティングプロトコルの確認

R1#sh ip protocols
Routing Protocol is "eigrp 1"・・・①
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0・・・②
  EIGRP maximum hopcount 100・・・③
  EIGRP maximum metric variance 1・・・④
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is in effect・・・⑤
  Maximum path: 4・・・⑥
  Routing for Networks:
    10.0.0.0・・・⑦
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.2.1.2・・・⑧        90      00:02:11
  Distance: internal 90 external 170・・・⑨

①有効化されているルーティングプロトコルは 「EIGRP」でAS番号が「1」
②K値の情報(0=未使用、1=使用)
 K1(帯域幅)=1
 K2(負荷)=0
 K3(遅延)=1
 K4(信頼性)=0
 K5(MTU)=0
③ホップカウントは「100」(最大255)
 EIGRPは、拡張ディスタンスベクタ型プロトコルでありホップ数制限がある。
④variance 1 は「等コストロードバランシング」
 (variance 2 以上は不等ロードバランシング)
⑤Automatic network summarization is in effectは、「自動集約有効」
 (Automatic network summarization is not in effectは、「自動集約無効」)
⑥ロードバランシング可能な最大数は「4」(最大16)
⑦EIGRPのnetworkコマンドで有効化されたインターフェースにおいて、通知されるネットワークの情報。
⑧EIGRPでルート情報をやりとりしているネクストホップルータのIPアドレス。
⑨アドミニストレーティブディスタンス値。
 内部EIGRPが 90、外部EIGRPが 170。

ルーティングテーブルの確認

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
D       10.3.1.0 [90/284160] via 10.2.1.2, 00:40:07, FastEthernet1/0・・・①
C       10.2.1.0 is directly connected, FastEthernet1/0
C       10.1.1.0 is directly connected, FastEthernet0/0

① EIGRPで学習したルートは、「D」、または「EX」で表示される。
D:EIGRPの内部ルート。該当ルータが参加するEIGRPのAS内で生成されたルート。
EX:EIGRPの外部ルート。該当ルータが参加するEIGRPのAS外で生成されて、再配送によってAS内に投入されたルート。

10.3.1.0
リモートネットワーク。

[90/284160]
90は、アドミニストレーティブディスタンス。
284160は、メトリック値。宛先ネットワークまでのFD値。

via 10.2.1.2
ネクストホップ。

00:40:07
宛先ルートを受信してから経過時間 。

FastEthernet1/0
宛先ネットワークに転送するための出力インターフェース。 (自分自身のインターフェースを指す)

ネイバーテーブルの確認

R1#sh ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.2.1.2                Fa1/0             11 04:13:51   31   200  0  6・・・①

① H
ネイバールータごとに割り当てられるCisco IOS内部で使用する値。

Address
ネイバールータのIPアドレス。「10.2.1.2」

Interface
ネイバールータと接続している自身のインターフェース。「Fa1/0」

Hold
ホールドタイマー。ネイバールータをダウンとみなすまでの時間。 「11」

Uptime
ネイバー確立からの経過時間。「04:13:51」

SRTT
ネイバールータにEIGRPパケットを送信してから、ACKを受信するまでにかかる平均時間。「31」

RTO
ネイバールータにEIGRPパケットを再送信するまでにACKを待つ時間。「200」

Q cnt
送信キューに格納されているEIGRPのパケット数。0が正常(輻輳が発生していない)

Seq Num
ネイバールータから受信した最後のEIGRPパケットのシーケンス番号。 「6」

トポロジーテーブルの確認

R1#sh ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.2.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.3.1.0/24, 1 successors, FD is 284160
        via 10.2.1.2 (284160/281600), FastEthernet1/0・・・①
P 10.2.1.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet1/0
P 10.1.1.0/24, 1 successors, FD is 281600
        via Connected, FastEthernet0/0

① P
ルートの状態を示すコード。
P:ルート情報がEIGRPの計算中ではないことを示すコード。
A:ルート情報がEIGRPの計算中であることを示すコード。
U:Updateパケットがこの宛先へ送信されたことを示すコード。
Q:Queryパケットがこの宛先へ送信されたことを示すコード。
R:Replyパケットがこの宛先へ送信されたことを示すコード。

10.3.1.0/24
宛先ネットワーク。

1 successors
サクセサのルート数。この例では1つのサクセサがあることを示す。

FD is 284160
サクセサのルートのFD値。

via 10.2.1.2
宛先ネットワークに対するネクストホップのIPアドレス。

(284160/281600)
FD/AD。
FD(フィージブルディスタンス):自ルータから宛先ネットワークまでのメトリック。
AD(アドバタイズドディスタンス):ネイバー(宛先ホップルータ)から宛先ネットワークまでのメトリック。

FastEthernet1/0
ルート情報が学習されたインターフェース。

動作確認

Pingの疎通テスト

PC-1からPC-2
PC-1> ping 10.3.1.100
10.3.1.100 icmp_seq=1 timeout
84 bytes from 10.3.1.100 icmp_seq=2 ttl=62 time=77.887 ms
84 bytes from 10.3.1.100 icmp_seq=3 ttl=62 time=96.565 ms
84 bytes from 10.3.1.100 icmp_seq=4 ttl=62 time=50.133 ms
84 bytes from 10.3.1.100 icmp_seq=5 ttl=62 time=38.863 ms
PC-2からPC-1
PC-2> ping 10.1.1.100
84 bytes from 10.1.1.100 icmp_seq=1 ttl=62 time=78.560 ms
84 bytes from 10.1.1.100 icmp_seq=2 ttl=62 time=68.947 ms
84 bytes from 10.1.1.100 icmp_seq=3 ttl=62 time=83.851 ms
84 bytes from 10.1.1.100 icmp_seq=4 ttl=62 time=78.068 ms
84 bytes from 10.1.1.100 icmp_seq=5 ttl=62 time=61.224 ms

異なるセグメントのPCがお互いに通信できることが確認できます。

タイトルとURLをコピーしました