BGPの設定

目的

異なるネットワークに所属している2台のPCをお互いに通信させます。
ルーティングプロトコルはRIPv1を使用しお互いのAS内のルート情報がBGPでアドバタイズされていることを確認します。

BGPの設定方法を学びます。

接続構成

設定

R1の設定

R1(config)#int f0/0
R1(config-if)#ip add 192.168.1.1 255.255.255.0
R1(config-if)#no shut

R1(config-if)#int f1/0
R1(config-if)#ip add 10.1.1.1 255.255.255.252
R1(config-if)#no shut

R1(config)#router bgp 1
AS番号1でBGPルーティングプロセスを有効にする
R1(config-router)#neighbor 10.1.1.2 remote-as 2
AS2の10.1.1.2のルータとピアを確立する
R1(config-router)#network 192.168.1.0 mask 255.255.255.0
192.168.1.0/24の経路情報をBGPで流す

R2の設定

R2(config)#int f0/0
R2(config-if)#ip add 192.168.3.1 255.255.255.0
R2(config-if)#no shut

R2(config-if)#int f1/0
R2(config-if)#ip add 10.1.1.2 255.255.255.252
R2(config-if)#no shut

R2(config)#router bgp 2
AS番号2でBGPルーティングプロセスを有効にする
R2(config-router)#neighbor 10.1.1.1 remote-as 1
AS1の10.1.1.1のルータとピアを確立する
R2(config-router)#network 192.168.3.0 mask 255.255.255.0
192.168.3.0/24の経路情報をBGPで流す

PC-1の設定

PC-1> ip 192.168.1.100/24 192.168.1.1
Checking for duplicate address...
PC1 : 192.168.1.100 255.255.255.0 gateway 192.168.1.1

PC-1> save
Saving startup configuration to startup.vpc
. done

PC-2の設定

PC-2> ip 192.168.3.100/24 192.168.3.1
Checking for duplicate address...
PC2 : 192.168.3.100 255.255.255.0 gateway 192.168.3.1

PC-2> save
Saving startup configuration to startup.vpc
. done

設定確認

ルーティングプロトコルの確認

R1#sh ip protocols
Routing Protocol is "bgp 1"・・・①
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  IGP synchronization is disabled
  Automatic route summarization is disabled
  Neighbor(s):
    Address          FiltIn FiltOut DistIn DistOut Weight RouteMap
    10.1.1.2・・・②
  Maximum path: 1
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.1.1.2              20      00:01:29
  Distance: external 20 internal 200 local 200

①有効化されているルーティングプロトコルは 「bgp」でAS番号が「1」
②「10.1.1.2」とネイバーを構成している

BGPの経路情報を確認(簡易)

R1#sh ip bgp summary
BGP router identifier 192.168.1.1, local AS number 1
BGP table version is 3, main routing table version 3
2 network entries using 240 bytes of memory
2 path entries using 104 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 772 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.1.1.2        4     2      23      23        3    0    0 00:19:45        1・・・①

①Neibhbor
BGPネイバーのIPアドレス。「10.1.1.2」

V
BGPのバージョン。「4」

AS
BGPネイバーのAS番号。「2」

MsgRcvd
受信したBGPメッセージ数。「23」

MsgSent
送信したBGPメッセージ数。「23」

TblVer
送信したBGPテーブルの最新バージョン。「0」

InQ
未処理の受信したBGPメッセージ数。「0」

OutQ
未送信のBGPメッセージ数。「0」

Up/Down
BGPセッションが確立されてからの経過時間。「00:19:45」

State/PfxRcd
BGPネイバから受信した経路数。「1」

BGPの経路情報を確認

R1#sh ip bgp
BGP table version is 3, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.1.0      0.0.0.0                  0         32768 i
*> 192.168.3.0      10.1.1.2                 0             0 2 i・・・①

①BGPルート
「*」 はこの経路情報が有効であることを示すステータスコードで「>」 はベストパスを示している。ベストパスの経路情報がルーティングテーブルに記載される

Network
宛先ネットワーク。「192.168.3.0」

Next Hop
ネクストホップ。「10.1.1.2」
0.0.0.0 と表示される場合はnetworkコマンド、または aggregate-addressコマンドを使ってローカルで生成されたルートを意味する。

Metric
MED属性値。デフォルト値は 0。隣接するAS内でのみ有効な値。 「0」

LocPrf
LocalPreference属性値。デフォルト値は 100。EBGPルートの場合は空欄で表示される。

Weight
Weight 属性値。デフォルト値は32768。AS内のローカルルート以外は 0 と表示される。

Path
AS Path属性値。AS番号がない場合、そのルートはAS内のルートであることを意味する。右端から順に経由したAS番号が表示。「i」はORIGINアトリビュートのIGP、「?」はIncomplete。

ルーティングテーブルの確認

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet1/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
B    192.168.3.0/24 [20/0] via 10.1.1.2, 01:38:37・・・①

① B
ルートの情報源、BGPのこと。

192.168.3.0/24
リモートネットワーク。

[20/0]
20は、アドミニストレーティブディスタンス。
0は、メトリック値。

via 10.1.1.2
ネクストホップ。

01:38:37
宛先ルートを受信してから経過時間 。

動作確認

Pingの疎通テスト

PC-1からPC-2
PC-1> ping 192.168.3.100
84 bytes from 192.168.3.100 icmp_seq=1 ttl=62 time=52.872 ms
84 bytes from 192.168.3.100 icmp_seq=2 ttl=62 time=38.852 ms
84 bytes from 192.168.3.100 icmp_seq=3 ttl=62 time=33.093 ms
84 bytes from 192.168.3.100 icmp_seq=4 ttl=62 time=42.082 ms
84 bytes from 192.168.3.100 icmp_seq=5 ttl=62 time=53.981 ms
PC-2からPC-1
PC-2> ping 192.168.1.100
84 bytes from 192.168.1.100 icmp_seq=1 ttl=62 time=35.805 ms
84 bytes from 192.168.1.100 icmp_seq=2 ttl=62 time=35.829 ms
84 bytes from 192.168.1.100 icmp_seq=3 ttl=62 time=45.987 ms
84 bytes from 192.168.1.100 icmp_seq=4 ttl=62 time=67.633 ms
84 bytes from 192.168.1.100 icmp_seq=5 ttl=62 time=37.203 ms

異なるセグメントのPCがお互いに通信できることが確認できます。

タイトルとURLをコピーしました